Siren 12 - migration error


I was using Siren 11 for the past couple of weeks. I tried to upgrade to Siren 12 but I can’t figure out how to overcome the migration errors I’m getting.

I installed a fresh version of Siren 12. Copied my Siren 11 elasticsearch/data folder into the new instance and followed the backup/restore/upgrade instructions I found online.

Getting the same error - There are 102 outdated or missing objects. Please run “bin/investigate upgrade” and restart the server.

I ran the command and restarted the sever but still nothing.

Please help. Thanks.

Hi James,

Can you please confirm from which minor version of Siren 11 (11.1.?) you are trying for upgrade to Siren 12 ?

Can you please attach the migration error you are getting?


Hello Manu,

Sure. It is version 11.1.7. Please see the migration error below:

log [22:39:12.276] [error][migrations] Error during migration.upgrade: Adds _source.siren.globalSearch context to savedSearch
log [22:39:12.277] [error][migrations] [illegal_argument_exception] mapper [search.siren.globalSearch.boost] cannot be changed from type [long] to [double] :: {“path”:"/.siren/_mapping",“query”:{“type”:“doc”,“include_type_name”:true},“body”:"{“doc”:{“properties”:{“search”:{“properties”:{“siren”:{“properties”:{“globalSearch”:{“properties”:{“enabled”:{“type”:“boolean”},“boost”:{“type”:“double”}}}}}}}}}}",“statusCode”:400,“response”:"{“error”:{“root_cause”:[{“type”:“illegal_argument_exception”,“reason”:“mapper [search.siren.globalSearch.boost] cannot be changed from type [long] to [double]”}],“type”:“illegal_argument_exception”,“reason”:“mapper [search.siren.globalSearch.boost] cannot be changed from type [long] to [double]”},“status”:400}"}
at respond (/opt/siren-investigate/node_modules/elasticsearch/src/lib/transport.js:349:15)
at checkRespForFailure (/opt/siren-investigate/node_modules/elasticsearch/src/lib/transport.js:306:7)
at HttpConnector. (/opt/siren-investigate/node_modules/elasticsearch/src/lib/connectors/http.js:173:7)
at IncomingMessage.wrapper (/opt/siren-investigate/node_modules/lodash/lodash.js:4991:19)
at IncomingMessage.emit (events.js:412:35)
at endReadableNT (internal/streams/readable.js:1334:12)
at processTicksAndRejections (internal/process/task_queues.js:82:21)
[illegal_argument_exception] mapper [search.siren.globalSearch.boost] cannot be changed from type [long] to [double] :: {“path”:"/.siren/_mapping",“query”:{“type”:“doc”,“include_type_name”:true},“body”:"{“doc”:{“properties”:{“search”:{“properties”:{“siren”:{“properties”:{“globalSearch”:{“properties”:{“enabled”:{“type”:“boolean”},“boost”:{“type”:“double”}}}}}}}}}}",“statusCode”:400,“response”:"{“error”:{“root_cause”:[{“type”:“illegal_argument_exception”,“reason”:“mapper [search.siren.globalSearch.boost] cannot be changed from type [long] to [double]”}],“type”:“illegal_argument_exception”,“reason”:“mapper [search.siren.globalSearch.boost] cannot be changed from type [long] to [double]”},“status”:400}"}
There was an error and the upgrade process failed.

Hi James,

This migration error comes if someone has imported NEW saved object(savedSearch from Siren 12) to old Siren Instance.

There is a dynamic mapping applied (which sets filed to LONG) onto NEW saved object in Siren 12. The property is only introduced in Siren 12. Not sure how you got this error while upgrading from Siren 11 to Siren 12.

Is it possible could provide us the data/backup which was taken before the upgrade.

You can share this details here


Hi James,

We able to replicate the issue on our side, we will be releasing 12.0.1 very soon which will fix this migration issue.


Hi Manu,

Great timing! I was just preparing a note to send you the data/backup files.

Thank you for the assist.

1 Like

Hi James,

We have released Siren 12.0.1 which will fix this migration issue while upgrading from 11.1.x to Siren 12.

Downloads are available here.