Migration reported outdated objects

Hi Team!

I would just like to reach out if anyone encountered the same error as below:

This happened when I tried to backup (./investigate backup --backup-dir=DIR) one Siren Platform and then restored it to another Siren Platform on another node. Here are my questions:

  1. Are the steps in Setting up Siren Investigate :: SIREN DOCS really just meant as an upgrade solution and not really migrating saved objects, indices, mapping etc. to another Siren Platform living on another node?

  2. I also noticed that when I restored the backup to another Siren Platform on another instance that the indices and data ingestion jobs where not migrated. Is this it the expected behavior?

Thank you in advance!

Iā€™m using Siren Platform 12.1 btw.

Thank you!

Hi Edgar,

You have to Run the following upgrade command:

bin/investigate upgrade

This is mentioned in the document at point number 7.


In your screen shot there is a message as well to run this upgrade command:

Manu Agarwal

1 Like

Hi @Manu_Agarwal

thank you for the response and apologies for my late reply, but quick follow-up on my #2 question, is it the expected that when running the backup, data import jobs are not included?

Thank you!