Image Proxy - Not Working

Please see my investigate.yml file configuration bellow:

investigate_core:
image_proxy:
enabled: true

Thanks again!

Hi Carol,

Can you please share if there any error in the siren console or in the logs after you have enabled the image proxy?

Also please confirm the Investigate version and Elasticsearch version you are on?

Regards
Manu Agarwal

Hi,

No errors in the console or the logs. I am using investigate version 11.0.2 and Elasticsearch version 7.4.

Thanks!

Hi Carol,

Please share the screenshot of the investigate management page like this:

Regards
Manu Agarwal

Sure. Please find it attached bellow.

Hi Carol,

I didn’t see any issue with the Image Proxy , it looks like the image size is creating an issue at your environment.

Please set the parameter value to more size as by default it is 10000 bytes.

max_image_size

https://docs.siren.io/siren-platform-user-guide/11.1/siren-investigate/image-proxy-ip.html

This should probably resolve the issue.

Regards
Manu Agarwal

Hey Manu,

Apologies for the delay… I have changed the max_image_size to 50000 but still nothing shows. I double checked the URL and it returns a valid response so I’m not sure what I’m missing…

Thanks again!

Hi Carol,

Sorry for the issue happening here , Would it possible for you to upgrade the Investigate to the latest version 11.1 or 11.0.2.

You can download it from here

You can follow these steps for upgrade:

  • Download the zip with Investigate 11.0.2 or 11.1. Unzip the folder.
  • Stop the current investigate running.
  • Go to the Investigate directory of newly downloaded.
  • Execute bin/investigate upgrade
  • Restart Investigate

Regards
Manu Agarwal

Good Morning Manu,

I just finished upgrading and everything works great!! Thank you again!

1 Like