Web Services - Heap Overflow

Hello,

I am trying to enable Web Services by modifying the configuration file as follows:

web_services:
global:
enabled: true
webhose:
config:
auth_token: ‘token’

Every time I save the changes and restart the server, I get the same error message saying javascript heap overflow…

Error:
log [09:55:54.571] [info][optimize] Optimizing and caching bundles for ingest, sentinl, web-service-manager, kibana, stateSessionStorageRedirect, timelion and status_page. This may take a few minutes

<— Last few GCs —>

[1288:00000198CFEDE120] 19527 ms: Mark-sweep 1394.0 (1421.4) → 1393.4 (1421.4) MB, 563.6 / 0.0 ms (average mu = 0.130, current mu = 0.099) allocation failure scavenge might not succeed
[1288:00000198CFEDE120] 20664 ms: Mark-sweep 1394.2 (1421.4) → 1393.6 (1421.9) MB, 1133.7 / 0.0 ms (average mu = 0.056, current mu = 0.003) allocation failure scavenge might not succeed

<— JS stacktrace —>

==== JS stack trace =========================================

0: ExitFrame [pc: 000001A2780DC5C1]

Security context: 0x0371a359e6c1
1: B(aka B) [0000018BC73DCF01] [C:\Users\Administrator\Downloads\siren-platform-easy-start-11.0.2-windows-x86_64\siren-investigate\node_modules\terser\dist\bundle.min.js:~1] [pc=000001A2783D2741](this=0x03c6a41826f1 )
2: G(aka G) [0000018BC73D2BC9] [C:\Users\Administrator\Downloads\siren-platform-easy-start-11.0.2-windows-x86_64\siren-in…

FATAL ERROR: Ineffective mark-compacts near heap limit Allocation failed - JavaScript heap out of memory
1: 00007FF7C18A87DA v8::internal::GCIdleTimeHandler::GCIdleTimeHandler+4506
2: 00007FF7C1883246 node::MakeCallback+4534
3: 00007FF7C1883BC0 node_module_register+2032
4: 00007FF7C1BA1A4E v8::internal::FatalProcessOutOfMemory+846

Hope you can help.

Thanks, Carol.

Hi Carol,

I believe you need to set this based on the OS you are on:

Set the node option in windows:

set NODE_OPTIONS=--max_old_space_size=4096

Set the node option in linux:

export NODE_OPTIONS=--max_old_space_size=4096

Once this set please start the investigate service which will resolve this issue.

If the issue still persist please share the complete error message you got.
Also here is correct format I hope this one is correct in the investigate.yml file:

web_services:
  global:
    enabled: true
  webhose:
    enabled: false
    config:
      auth_token: 'change-me'
  jsonwhois:
    enabled: false
    config:
      auth_token: 'change-me'
  twitter:
    enabled: false
    config:
      key: 'change-me'
      secret: 'change-me'

Thanks
Manu Agarwal

Hi Manu,

I apologize for the delay… Thank you very much for your help!!

1 Like

Hi Manu,

Hope you are doing well. I was hoping I could use your help once again. I am trying to use Image Proxy but even after enabled, I can’t seem to get it working on the graph… Thanks again!!

Hi Carol,

Sorry for the delay in reply.

Can you please have a new post for this issue and provide the investigate.yml file configuration you use for the image proxy with an error you are getting.

Regards
Manu Agarwal

Hi Manu,

Absolutely. Thank you.