# Vertica JDBC Issue

**URL:** https://community.siren.io/t/vertica-jdbc-issue/125
**Category:** Siren Platform/Investigate Tech Support Community
**Created:** [September 5, 2019, 6:47am UTC](https://community.siren.io/t/vertica-jdbc-issue/125 "2019-09-05T06:47:24Z")
**Posts on this page:** 5
**Page:** 1

<div class="post-metadata">

### Author: ![jansoft](https://avatars.discourse-cdn.com/v4/letter/j/b38774/32.png) [@jansoft](https://community.siren.io/u/jansoft)
#### Post date: [September 5, 2019, 6:47am UTC](https://community.siren.io/t/vertica-jdbc-issue/125/1 "2019-09-05T06:47:24Z")

</div>

Hi,

I am currently trying to connect to Vertica via siren JDBC but i am having trouble getting it to work.

siren version : 10.2.4

Things i have done:

- Added vertica jdbc driver into the drivers folder
- Used the same jdbc class, connection string that i use for other application:  
jdbc\_driver\_class =\> “com.vertica.jdbc.Driver”  
jdbc\_connection\_string =\> "jdbc\_connection\_string =\> “jdbc:vertica://10.50.1.50:5433/”

Error Code:  
Datasources Configuration Editor: Could not validate datasource [vertica]. {“error”:{“root\_cause”:[{“type”:“exception”,“reason”:“Could not validate datasource [vertica].”}],“type”:“exception”,“reason”:“Could not validate datasource [vertica].”,“caused\_by”:{“type”:“exception”,“reason”:“Could not execute datasource query.”,“caused\_by”:{“type”:“no\_class\_def\_found\_error”,“reason”:“Could not initialize class com.vertica.jdbc.Driver”}}},“status”:500}

Appreciate any input and help on the matter.

---

<div class="post-metadata">

### Author: ![varun.sharma](https://yyz2.discourse-cdn.com/flex032/user_avatar/community.siren.io/varun.sharma/32/46_2.png) [@varun.sharma](https://community.siren.io/u/varun.sharma)
#### Post date: [September 5, 2019, 9:17am UTC](https://community.siren.io/t/vertica-jdbc-issue/125/2 "2019-09-05T09:17:07Z")

</div>

Hello jansoft,  
Just to be sure,I hope you placed the driver jar in: `${your_workspace}/elasticsearch/config/jdbc-drivers` (As per [docs](https://docs.support.siren.io/10.2.4/platform/en/siren-federate/connecting-to-jdbc-datasources/jdbc-driver-installation-and-compatibility.html)). If the given node was running while you place the driver, you would need to restart the node. And make sure the class `com.vertica.jdbc.Driver` does exist in the given jar.  
This should sort it out.

Regards,  
Varun

---

<div class="post-metadata">

### Author: ![jansoft](https://avatars.discourse-cdn.com/v4/letter/j/b38774/32.png) [@jansoft](https://community.siren.io/u/jansoft)
#### Post date: [September 6, 2019, 3:24am UTC](https://community.siren.io/t/vertica-jdbc-issue/125/3 "2019-09-06T03:24:19Z")

</div>

Hello varun,

Thank you for the reply,

I tried rebooting the server and restarting the node, but no luck, same error.

I have placed vertica.jar on /elasticsearch/config/jdbc-drivers

 ![Screenshot_3](https://canada1.discourse-cdn.com/flex032/uploads/siren/original/1X/5e9af4ed92f4baf42c5e2332ea4eac20ee7dc4ef.png)

I am not sure if the class `com.vertica.jdbc.Driver` exist in the jar, but i have been using the same jar and driver class on all my other application and they seem to work without much trouble.

---

<div class="post-metadata">

### Author: ![varun.sharma](https://yyz2.discourse-cdn.com/flex032/user_avatar/community.siren.io/varun.sharma/32/46_2.png) [@varun.sharma](https://community.siren.io/u/varun.sharma)
#### Post date: [September 6, 2019, 9:49am UTC](https://community.siren.io/t/vertica-jdbc-issue/125/4 "2019-09-06T09:49:11Z")

</div>

Could you provide the error logs generated in elasticsearch?

It also appears that you might need to add a permission for the driver to work properly (After initialization):  
`permission java.io.FilePermission "vertica.properties", "read";`  
In two of our security policy files:  
`drivers-security.policy` (Inside grant block for `${codebase.federate.common}`)  
`plugin-security.policy`

---

<div class="post-metadata">

### Author: ![jansoft](https://avatars.discourse-cdn.com/v4/letter/j/b38774/32.png) [@jansoft](https://community.siren.io/u/jansoft)
#### Post date: [September 9, 2019, 8:58am UTC](https://community.siren.io/t/vertica-jdbc-issue/125/5 "2019-09-09T08:58:46Z")

</div>

Dear Varun,

Thank you for the reply,

I tried adding “permission java.io.FilePermission “vertica.properties”, “read”;” to drivers-security.policy and plugin-security.policy:  
 ![Screenshot_12](https://canada1.discourse-cdn.com/flex032/uploads/siren/original/1X/70b5c0c5d54d014a0d8b3293382a0c7a95ddc8b4.png)

And i am getting a new error:

> Datasources Configuration Editor: Could not validate datasource [vertica]. {“error”:{“root\_cause”:[{“type”:“exception”,“reason”:“Could not validate datasource [vertica].”}],“type”:“exception”,“reason”:“Could not validate datasource [vertica].”,“caused\_by”:{“type”:“pool\_initialization\_exception”,“reason”:“Failed to initialize pool: [Vertica]access denied ("java.io.FilePermission" "/usr/lib/jvm/java-1.8.0-openjdk-1.8.0.222.b10-0.el7\_6.x86\_64/jre/security/jssecacerts" "read")”,“caused\_by”:{“type”:“s\_q\_l\_exception”,“reason”:“[Vertica]access denied ("java.io.FilePermission" "/usr/lib/jvm/java-1.8.0-openjdk-1.8.0.222.b10-0.el7\_6.x86\_64/jre/security/jssecacerts" "read")”,“caused\_by”:{“type”:“access\_control\_exception”,“reason”:“access denied ("java.io.FilePermission" "/usr/lib/jvm/java-1.8.0-openjdk-1.8.0.222.b10-0.el7\_6.x86\_64/jre/security/jssecacerts" "read")”}}}},“status”:500}

Elasticsearch.log when i press test connection in siren:

> **[elastic.log - Pastebin.com](https://pastebin.com/BzUzv9zr)**
>
> Pastebin.com is the number one paste tool since 2002. Pastebin is a website where you can store text online for a set period of time.
