# Java probleme running elastic

**URL:** <https://community.siren.io/t/java-probleme-running-elastic/285>\
**Category:** Siren Platform/Investigate Tech Support Community\
**Created:** [July 23, 2020, 7:09pm UTC](https://community.siren.io/t/java-probleme-running-elastic/285 "2020-07-23T19:09:16Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![nadvig](https://avatars.discourse-cdn.com/v4/letter/n/f6c823/32.png) [@nadvig](https://community.siren.io/u/nadvig)\
**Post date:** [July 23, 2020, 7:09pm UTC](https://community.siren.io/t/java-probleme-running-elastic/285/1 "2020-07-23T19:09:16Z")

</div>

hello i have installed the Siren community version on my Ubuntu 20.04 laptop…no errors. Now i have installed on a Ubuntu server 20.04 i got this error :

/opt/Siren/siren-platform-easy-start-10.5.1-linux-x86\_64/elasticsearch$ sudo ./bin/elasticsearch  
OpenJDK 64-Bit Server VM warning: Option UseConcMarkSweepGC was deprecated in version 9.0 and will likely be removed in a future release.  
[2020-07-23T15:05:55,880][WARN][o.e.b.ElasticsearchUncaughtExceptionHandler] [siren-node] uncaught exception in thread [main]  
org.elasticsearch.bootstrap.StartupException: java.lang.RuntimeException: can not run elasticsearch as root  
at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:163) ~[elasticsearch-7.3.2.jar:7.3.2]  
at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:150) ~[elasticsearch-7.3.2.jar:7.3.2]  
at org.elasticsearch.cli.EnvironmentAwareCommand.execute(EnvironmentAwareCommand.java:86) ~[elasticsearch-7.3.2.jar:7.3.2]  
at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:124) ~[elasticsearch-cli-7.3.2.jar:7.3.2]  
at org.elasticsearch.cli.Command.main(Command.java:90) ~[elasticsearch-cli-7.3.2.jar:7.3.2]  
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:115) ~[elasticsearch-7.3.2.jar:7.3.2]  
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:92) ~[elasticsearch-7.3.2.jar:7.3.2]  
Caused by: java.lang.RuntimeException: can not run elasticsearch as root  
at org.elasticsearch.bootstrap.Bootstrap.initializeNatives(Bootstrap.java:105) ~[elasticsearch-7.3.2.jar:7.3.2]  
at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:172) ~[elasticsearch-7.3.2.jar:7.3.2]  
at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:349) ~[elasticsearch-7.3.2.jar:7.3.2]  
at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:159) ~[elasticsearch-7.3.2.jar:7.3.2]

because of this error Investigate cannot run of course:

dkcop@ged:/opt/Siren/siren-platform-easy-start-10.5.1-linux-x86\_64/siren-investigate$ sudo ./bin/investigate  
log [19:06:30.211] [info][status][plugin:kibana@10.5.1] Status changed from uninitialized to green - Ready  
log [19:06:30.215] [info][status][plugin:clientside\_compression@10.5.1] Status changed from uninitialized to green - Ready  
log [19:06:30.217] [info][elasticsearch] Fetching Elasicsearch API Version.  
log [19:06:30.233] [error][status][plugin:elasticsearch@10.5.1] Status changed from uninitialized to red - Unable to connect to Elasticsearch at [http://localhost:9220](http://localhost:9220)  
log [19:06:30.234] [error][elasticsearch] Client request error: connect ECONNREFUSED 127.0.0.1:9220  
log [19:06:32.743] [error][elasticsearch] Client request error: connect ECONNREFUSED 127.0.0.1:9220

i have installed Java :  
/opt/Siren/siren-platform-easy-start-10.5.1-linux-x86\_64/elasticsearch$ java -version  
openjdk version “1.8.0\_252”  
OpenJDK Runtime Environment (build 1.8.0\_252-8u252-b09-1ubuntu1-b09)  
OpenJDK 64-Bit Server VM (build 25.252-b09, mixed mode)

i have set up also the env. variable…

what\<s the problem…^^^ thanks!

---

<div class="post-metadata">

**Author:** ![varun.sharma](https://yyz2.discourse-cdn.com/flex032/user_avatar/community.siren.io/varun.sharma/32/46_2.png) [@varun.sharma](https://community.siren.io/u/varun.sharma)\
**Post date:** [July 23, 2020, 7:43pm UTC](https://community.siren.io/t/java-probleme-running-elastic/285/2 "2020-07-23T19:43:49Z")

</div>

Hello @nadvig,  
As I can see from the logs, the problem appears to be:  
`org.elasticsearch.bootstrap.StartupException: java.lang.RuntimeException: can not run elasticsearch as root`  
I’d recommend running elasticsearch via: `./bin/elasticsearch` rather than adding sudo. And if you get `AccessDeniedException` on any config file then take ownership of it via chown. [More info](https://github.com/elastic/elasticsearch/blob/2774cd6938bb5dff3fa31c2dd9d2b8c592ab1222/docs/reference/scripting/security.asciidoc#do-not-run-as-root) on why you should not run elasticsearch as root.

Regards,  
Varun

---

<div class="post-metadata">

**Author:** ![nadvig](https://avatars.discourse-cdn.com/v4/letter/n/f6c823/32.png) [@nadvig](https://community.siren.io/u/nadvig)\
**Post date:** [July 23, 2020, 8:07pm UTC](https://community.siren.io/t/java-probleme-running-elastic/285/3 "2020-07-23T20:07:22Z")

</div>

thanks, i have change ownership to all the files in /bin…  
Exception in thread “main” java.nio.file.AccessDeniedException: /opt/Siren/siren-platform-easy-start-

---

<div class="post-metadata">

**Author:** ![nadvig](https://avatars.discourse-cdn.com/v4/letter/n/f6c823/32.png) [@nadvig](https://community.siren.io/u/nadvig)\
**Post date:** [July 24, 2020, 1:45am UTC](https://community.siren.io/t/java-probleme-running-elastic/285/4 "2020-07-24T01:45:36Z")

</div>

Everything is ok now!!! Yeah!
