How to run Siren platform from docker

Hello everyone,

I tried to run the docker image sirensolutions/siren-platform-demo-data:latest like specified from the tutorial, but when running the container nothing happens.
The container doesn’t seem to have a configured entrypoint.

Should I start each service manually?

I got this error by trying to run elasticsearch:
Caused by: java.lang.RuntimeException: can not run elasticsearch as root

This made me think that this is not the way the container is meant to be run.

Can anyone give an advice?

Thank you in advance!

Hello Antonio,

Which operating system are you using? I presume Linux
Likewise, could you help me with the steps which led you to the error which you have listed.


Yes it is an AWS instance running the Amazon Linux OS.

I just run the docker command suggested in the tutorial:
docker run -d -p 5606:5606 -p 9220:9220 sirensolutions/siren-platform-demo-data:latest

Then from inside the container I tried to execute the elasitcsearch executable ./opt/platform/elasticsearch/bin/elasticsearch

Hi Antonio,

The command above should automatically start both Siren and Elasticsearch. There is no need to start Siren and Elasticsearch separately. So, the following steps should help

  1. Run docker run -d -p 5606:5606 -p 9220:9220 sirensolutions/siren-platform-demo-data:latest at the Terminal command prompt.
  2. Once the above command finishes executing, open your browser and enter the following URL: http://localhost:5606. This will bring up Siren Investigate Login page. You can enter sirenadmin/password
  3. If you like to see Elasticsearch, then enter the following URL: https://localhost:9220. Next, a self-signed certificate warning will be displayed. You can safely ignore this and proceed. You will be prompted for authentication. Enter sirenserver/password

Hope this is helpful.

Nope, there is no service running in the container.

$ docker top 2faee3c981ca -H
PID                 TTY                 TIME                CMD
3106                ?                   00:00:00            sh
3165                ?                   00:00:00  
3169                ?                   00:00:00            supervisord

It doesn’t seem to me that neither elasticsearch or siren are running.

Remove the -H from this command: docker top 2faee3c981ca
However, please run http://localhost:5606 in your browser to comprehensively know whether Siren Investigate is running correctly.

This is how my environment looks like